Skip to content

設定 Firefox Aurora 相容性

轉眼間 Firefox 就快來到版本 7 了,這種快速更新的步伐,很多人都不習慣,也引起很多爭議。很多人說,Firefox 這般快的更新版本,很多插件都趕不及兼容,用不上,結果就拒絕更新。

這種快速更新的想法,其實就是想去掉版本號,不用理版本,隨時都是最新近的更新。能夠如此蓋因於大多數網頁都對標準支持得不錯,不會只用某某瀏覽器某某版本的某某功能才能走得動,也因為網絡速度更好,可以恒常更新。當然對於某些人來說,這代表一種入侵和控制,自動更新的軟件,操控我們資料的生殺大權,沒有保障。這是長久以來的兩難:要方便還是要私隱?

我自己是用 Firefox Aurora 版本的,隨時會自動更新,現在已經是 8.0a2。而我自已使用的經驗是,大多數插件其實都還可以用的沒有問題。只要叫 Firefox 不要管相容性就好了,方法是在網址列打 about:config,開新的 Boolean,打入如 extensions.checkCompatibility.8.0a (看你想要的版本),設定為 false 就好了。

當然長遠來說,當然是將這個相容性測試自動化。由現在開發者自行決定支持版本,變成程式自動測試就好了。

Jacky27 Sep 11 2:31 am 寫關於科技

Tags: , , [ 永久連結 | 引用 | 回應 RSS ]

發表回應